QMapShack & Linux Mint 19.x

Ende Juni 2018 wurde Linux Mint 19 veröffentlicht. Linux Mint 19 basiert auf Ubuntu 18.04 LTS.

Viel Spaß beim selber kompilieren!

Cmake & g++ installieren
sudo apt-get install cmake g++ cmake-curses-gui

Qt 5.9.5 installieren
sudo apt-get install qt5-default qttools5-dev-tools qttools5-dev qttools5-private-dev qtwebengine5-dev libqt5sql5-mysql

GitHub und Subversion
sudo apt-get install git subversion

C-Compiler, Make und andere benötigte Abhängigkeiten
sudo apt-get install gcc make libalglib-dev libc6-dev zlib1g-dev libbz2-dev libgraphics-magick-perl

OpenGL
sudo apt-get install freeglut3 freeglut3-dev

GDAL & Proj4
UbuntuGIS-unstable PPA hinzufügen

sudo add-apt-repository ppa:ubuntugis/ubuntugis-unstable
sudo apt-get update

sudo apt-get install gdal-bin libgdal-dev python3-gdal python3-dev libgeo-proj4-perl libproj-dev

QuaZip
sudo apt-get install libquazip5-headers libquazip5-1 libquazip5-dev

Zuerst installieren wir Routino:
svn co http://routino.org/svn/trunk routino
cd routino
make
sudo make install
und
cd .. ausführen.

Und jetzt holen wir uns QMapShack, direkt aus dem aktuellen Entwicklungsstrang:
git clone https://github.com/Maproom/qmapshack.git QMapShack, in den Ordner mit
cd QMapShack wechseln und
git checkout dev ausführen und
cd .. ausführen.

Jetzt brauchen wir noch ein „build“ Verzeichnis:
mkdir build_QMapShack und mit
cd build_QMapShack wechseln wir in das soeben erstellte Verzeichnis.

Mit folgendem Befehl setzen wir nun zum ersten Schritt an:
ccmake ../QMapShack.

Danach c und g ausführen.

Zurück in der Konsole dann noch
make ausführen und mit
sudo make install ist QMapShack installiert.

Um QMapShack zu aktualisieren, einfach in den Ordner /QMapShack wechseln und git pull ausführen. Neue Dateien werden mit diesem Befehl aktualisiert und zusammengeführt. Danach wieder in den Ordner /build_QMapShack wechseln und make && sudo make install ausführen.

7 Kommentare

  1. Hallo Emi,
    ich wollte mir gerade die 1.13er Version von QMS kompilieren, hab aber ne Fehlemeldung bei cmake bekommen. So wie es aussieht, gibt es Problem mit dem proj4-Paket. Aus den Hinweisen von Kiozen und Co werde ich nicht schlau. Hast Du vielleicht eine Idee, wie ich da machen muss?

    schon mal vielen Dank

    Robert

  2. Great documentation, just installed it on 2 Linux Mint 19.1 without any bigger troubles….
    then only thing I’m bit puzzled about are warnings about deprecated (always the same cause, same deprecated warning at different locations), but as it’s only a warning and all runs fine I’m not really concerned:

    [ 59%] Building CXX object src/qmapshack/CMakeFiles/qmapshack.dir/map/CMapVRT.cpp.o
    /data/develop/QMapShack/src/qmapshack/map/CMapVRT.cpp: In constructor ‘CMapVRT::CMapVRT(const QString&, CMapDraw*)’:
    /data/develop/QMapShack/src/qmapshack/map/CMapVRT.cpp:122:28: warning: ‘OGRErr OGRSpatialReference::importFromWkt(char**)’ is deprecated [-Wdeprecated-declarations]
    oSRS.importFromWkt(&wkt);
    ^
    In file included from /usr/include/gdal/ogr_geometry.h:38:0,
    from /usr/include/gdal/ogr_feature.h:36,
    from /usr/include/gdal/gdal_priv.h:77,
    from /data/develop/QMapShack/src/qmapshack/map/CMapVRT.cpp:25:
    /usr/include/gdal/ogr_spatialref.h:209:17: note: declared here
    OGRErr importFromWkt( char ** )

    Cheers keenonkites

  3. Hallo,

    Ich habe gerade die auf Engisch ubersetzte Seite von https://github.com/Maproom/qmapshack/wiki/BuildLinuxMint19, die von hieroben ubersetzt wurde, gefolgt und hat alles super geklappte (QMS 1.14.1 auf Linux Mint 19.3)

    Das hat alles super funktioniert und siet Toll aus. Vielen Dank dafur.

    Ich kam jedoch beim installieren von GDAL und Proj4 die fehler Meldung von hierunten. So weit ich gesehen habe hatte dies jedoch kein Einwurking.

    Ist dies weiter OK und soll dies ignoriert werden oder braucht dies ein Aenderung?

    patrick@Latitude-E7470:~$ sudo apt-get install gdal-bin libgdal-dev python-gdal libgeo-proj4-perl libproj-dev
    Reading package lists… Done
    Building dependency tree
    Reading state information… Done
    gdal-bin is already the newest version (3.0.4+dfsg-1~bionic0).
    libgdal-dev is already the newest version (3.0.4+dfsg-1~bionic0).
    libproj-dev is already the newest version (7.0.0-1~bionic0).
    Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:

    The following packages have unmet dependencies.
    gdal-bin : Breaks: python-gdal (= 2.4.0) but it is not going to be installed
    E: Unable to correct problems, you have held broken packages.

    1. Halo Patrick,
      das ist OK – die ersten drei Pakete sind schon installiert. Das Problem ist python-gdal – installiere mit sudo apt-get install python3-gdal, dann sollte es passen. Das Paket wird aber automatisch mit der angegebenen Codezeile mitinstalliert (also auch ohne python3-gdal), daher passt es auch beim Kompilieren. Habe die Anleitung angepasst.

      Danke für den Hinweis!

      emi@emi-GL553VD:~$ sudo apt-get install gdal-bin libgdal-dev libgeo-proj4-perl libproj-dev
      [sudo] Passwort für emi:
      Paketlisten werden gelesen… Fertig
      Abhängigkeitsbaum wird aufgebaut.
      Statusinformationen werden eingelesen…. Fertig
      Die folgenden zusätzlichen Pakete werden installiert:
      libgeotiff-dev python3-gdal
      Vorgeschlagene Pakete:
      libgdal-grass libgdal-doc libgeotiff-epsg proj-bin
      Die folgenden NEUEN Pakete werden installiert:
      gdal-bin libgdal-dev libgeo-proj4-perl libgeotiff-dev libproj-dev python3-gdal
      0 aktualisiert, 6 neu installiert, 0 zu entfernen und 0 nicht aktualisiert.
      Es müssen 19,8 MB an Archiven heruntergeladen werden.
      Nach dieser Operation werden 152 MB Plattenplatz zusätzlich benutzt.
      Möchten Sie fortfahren? [J/n] j
      Holen:1 http://ppa.launchpad.net/ubuntugis/ubuntugis-unstable/ubuntu bionic/main amd64 python3-gdal amd64 3.0.4+dfsg-1~bionic0 [760 kB]
      Holen:2 http://ubuntu.inode.at/ubuntu bionic/universe amd64 libgeo-proj4-perl amd64 1.09-1 [23,4 kB]
      Holen:3 http://ppa.launchpad.net/ubuntugis/ubuntugis-unstable/ubuntu bionic/main amd64 gdal-bin amd64 3.0.4+dfsg-1~bionic0 [500 kB]
      Holen:4 http://ppa.launchpad.net/ubuntugis/ubuntugis-unstable/ubuntu bionic/main amd64 libproj-dev amd64 7.0.0-1~bionic0 [10,8 MB]
      Holen:5 http://ppa.launchpad.net/ubuntugis/ubuntugis-unstable/ubuntu bionic/main amd64 libgeotiff-dev amd64 1.5.1-2~bionic2 [100 kB]
      Holen:6 http://ppa.launchpad.net/ubuntugis/ubuntugis-unstable/ubuntu bionic/main amd64 libgdal-dev amd64 3.0.4+dfsg-1~bionic0 [7.659 kB]
      Es wurden 19,8 MB in 10 s geholt (2.084 kB/s).
      Vormals nicht ausgewähltes Paket python3-gdal wird gewählt.

Kommentar hinterlassen

Deine E-Mail-Adresse wird nicht veröffentlicht.